Hello coders, today we will be solving The Minion Game in Python Hacker Rank Solution.
Task
Kevin and Stuart want to play the 'The Minion Game'.
Game Rules
Both players are given the same string, S.
Both players have to make substrings using the letters of the string S.
Stuart has to make words starting with consonants.
Kevin has to make words starting with vowels.
The game ends when both players have made all possible substrings.
Scoring
A player gets +1 point for each occurrence of the substring in the string S.
For Example
String S = BANANA Kevin's vowel beginning word = ANA Here, ANA occurs twice in BANANA. Hence, Kevin will get 2 Points.
Your task is to determine the winner of the game and their score.
Input Format:
A single line of input containing the string S.
Note: The string S will contain only uppercase letters: [A - Z].
Constraints
0 <= len(S) <= 10^6
Output Format
Print one line: the name of the winner and their score separated by a space.
If the game is a draw, print Draw.
Sample Input
BANANA
Sample Output
Stuart 12
Solution - The Minion Game in Python - Hacker Rank Solution
def minion_game(string): # your code goes here vowel = 'aeiou'.upper() strl = len(string) kevin = sum(strl-i for i in range(strl) if string[i] in vowel) stuart = strl*(strl + 1)/2 - kevin if kevin == stuart: print ('Draw') elif kevin > stuart: print ('Kevin %d' % kevin) else: print ('Stuart %d' % stuart) if __name__ == '__main__': s = input() minion_game(s)
Disclaimer: The above Problem (The Minion Game) is generated by Hacker Rank but the Solution is provided by Sloth Coders.
Happy Coding !!
A Sloth Who loves to Code
Also Read: