Capitalize! in Python - Hacker Rank Solution

Hello coders, today we will be solving Capitalize! in Python Hacker Rank Solution. You are asked to ensure that the first and last names of people beg

Hello coders, today we will be solving Capitalize! in Python Hacker Rank Solution.

Capitalize! in Python - Hacker Rank Solution

Problem

You are asked to ensure that the first and last names of people begin with a capital letter in their passports. For example, alison heck should be capitalized correctly as Alison Heck.

alison heck  - Alison Heck

Given a full name, your task is to capitalize the name appropriately.

Input Format

A single line of input containing the full name, S.

Constraints

  • 0 < len(S) < 1000
  • The string consists of alphanumeric characters and spaces.

Note: in a word only the first character is capitalized. Example 12abc when capitalized remains 12abc.

Output Format 

Print the capitalized string, S.

Sample Input

chris alan

Sample Output 

Chris Alan

Solution - Capitalize! in Python - Hacker Rank Solution 

#!/bin/python3

import math
import os
import random
import re
import sys

# Complete the solve function below.
def solve(s):
    for x in s[:].split():
        s = s.replace(x, x.capitalize())
    return s

if __name__ == '__main__':
    fptr = open(os.environ['OUTPUT_PATH'], 'w')

    s = input()

    result = solve(s)

    fptr.write(result + '\n')

    fptr.close()

Disclaimer: The above Problem (Capitalize! in Python) is generated by Hacker Rank but the Solution is provided by Sloth Coders.

Happy Coding !!

A Sloth Who loves to Code 

Also Read:

Sloth Coders is a Learning Platform for Coders, Programmers and Developers to learn from the basics to advance of Coding of different langauges(python, Java, Javascript and many more).

Post a Comment