String Split and Join - Hacker Rank Solution

Hello coders, today we will be solving String Split and Join Hacker Rank Solution in python. In Python, a string can be split on a delimiter.

Hello coders, today we will be solving String Split and Join Hacker Rank Solution in python.

String Split and Join - Hacker Rank Solution

Objective

In Python, a string can be split on a delimiter.

Example

>>> a = "this is a string"
>>> a = a.split(" ") # a is converted to a list of strings. 
>>> print a
['this', 'is', 'a', 'string']

Joining a string is simple:

>>> a = "-".join(a)
>>> print a
this-is-a-string 

Task

You are given a string. Split the string on a " " (space) delimiter and join using a - hyphen.

Input Format

The first line contains a string consisting of space separated words.

Output Format

Print the formatted string as explained above.

Sample Input

this is a string

Sample Output 

this-is-a-string

Solution - String Split and Join - Hacker Rank Solution 

def split_and_join(line):
    # write your code here
    line = line.split()
    line = "-".join(line)
    return line

if __name__ == '__main__':
    line = input()
    result = split_and_join(line)
    print(result)

Disclaimer: The above Problem (String Split and Join) is generated by Hacker Rank but the Solution is provided by Sloth Coders.

Happy Coding !!

A Sloth Who loves to Code

Also Read:

Sloth Coders is a Learning Platform for Coders, Programmers and Developers to learn from the basics to advance of Coding of different langauges(python, Java, Javascript and many more).

Post a Comment