Nested Lists in Python - Hacker Rank Solution

Hello coders, today we will be solving Nested Lists in Python Hacker Rank Solution. Given the names and grades for each student in a class of N studen

Hello coders, today we will be solving Nested Lists in Python Hacker Rank Solution.

Nested Lists in Python - Hacker Rank Solution

Problem

Given the names and grades for each student in a class of N students, store them in a nested list and print the name(s) of any student(s) having the second lowest grade.

Note: If there are multiple students with the second lowest grade, order their names alphabetically and print each name on a new line.

Example

records  = [[ "chi", 20.0]], ["beta", 50.0], ["alpha", 50.0]

The ordered list of scores is [20.0, 50.0], so the second lowest score is 50.0. There are two students with that score: ["beta", "alpha"]. Ordered alphabetically, the names are printed as:

alpha
beta

Input Format

The first line contains an integer, , the number of students.

The  subsequent lines describe each student over  lines.

  • The first line contains a student's name.
  • The second line contains their grade.

Constraints

  • 2 <= N <= 5
  • There will always be one or more students having the second lowest grade.

Output Format

Print the name(s) of any student(s) having the second lowest grade in. If there are multiple students, order their names alphabetically and print each one on a new line.

Sample Input 0

5
Harry
37.21
Berry
37.21
Tina
37.2
Akriti
41
Harsh
39

Sample Output 0

Berry
Harry

Explanation 0

There are 5 students in this class whose names and grades are assembled to build the following list:

python students = [['Harry', 37.21], ['Berry', 37.21], ['Tina', 37.2], ['Akriti', 41], ['Harsh', 39]]

The lowest grade of 37.2 belongs to Tina. The second lowest grade of 37.21 belongs to both Harry and Berry, so we order their names alphabetically and print each name on a new line.

Solution - Nested Lists in Python - Hacker Rank Solution 

Result =[]
scorelist = []

if __name__ == '__main__':
    for _ in range(int(input())):
        name = input()
        score = float(input())
        Result+=[[name,score]]
        scorelist+=[score]
    b=sorted(list(set(scorelist)))[1] 

    for a,c in sorted(Result):
        if c==b:
            print(a)

Disclaimer: The above Problem (Nested Lists in Python) is generated by Hacker Rank but the Solution is provide by Sloth Coders.

Happy Coding !!

A Sloth Who loves to Code

Also Read:

Sloth Coders is a Learning Platform for Coders, Programmers and Developers to learn from the basics to advance of Coding of different langauges(python, Java, Javascript and many more).

Post a Comment