For Loop in C - HackerRank Solution

Hello coders, today we will be solving For Loop in C HackerRank Solution. In this challenge, you will learn the usage of the for loop, which is a prog

Hello coders, today we will be solving For Loop in C HackerRank Solution.

For Loop in C - HackerRank Solution

Objective

In this challenge, you will learn the usage of the for loop, which is a programming language statement which allows code to be executed until a terminal condition is met. They can even repeat forever if the terminal condition is never met.

The syntax for the for loop is:

for ( <expression_1> ; <expression_2> ; <expression_3> )
    <statement>

  • expression_1 is used for intializing variables which are generally used for controlling the terminating flag for the loop.
  • expression_2 is used to check for the terminating condition. If this evaluates to false, then the loop is terminated.
  • expression_3 is generally used to update the flags/variables.

The following loop initializes i to 0, tests that i is less than 10, and increments i at every iteration. It will execute 10 times.

for(int i = 0; i < 10; i++) {
    ...
}

Task

For each integer n in the interval [a, b]  (given as input) :

  • If 1 ≤  n ≤ 9, then print the English representation of it in lowercase. That is "one" for 1, "two" for 2, and so on.
  • Else if n >9 and it is an even number, then print "even".
  • Else if n > 9 and it is an odd number, then print "odd".

Input Format 

The first line contains an integer, a.

The second line contains an integer, b.

Constraints

≤ a ≤ b ≤ 103 

Output Format

Print the appropriate English representation,even, or odd, based on the conditions described in the 'task' section.

Sample Input

8
11

Sample Output 

eight
nine
even
odd

Solution - For Loops in C - HackerRank Solution 

#include <string.h>
#include <math.h>
#include <stdlib.h>

int main() 
{
    int a=0,b=0,n=0;
    char* arr[10]={"zero","one","two","three","four","five","six","seven","eight","nine"};
    scanf("%d",&a);
    scanf("%d",&b);

    for(n = a;n<=b;n++)
    {
       if(n == 1) {
        printf("one\n");
    }
    else if(n == 2) {
        printf("two\n");
    }
    else if(n == 3) {
        printf("three\n");
    }
    else if(n == 4) {
        printf("four\n");
    }
    else if(n == 5) {
        printf("five\n");
    }
    else if(n == 6) {
        printf("six\n");
    }
    else if(n == 7) {
        printf("seven\n");
    }
    else if(n == 8) {
        printf("eight\n");
    }
    else if(n == 9) {
        printf("nine\n");
    }
    else {
        if(n %2 ==0)
            printf("even\n");
        else
           printf("odd\n");
    }
    }
    return 0;
}f(n %2 ==0)
            printf("even\n");
        else
           printf("odd\n");
    }
    }
    return 0;
}

Disclaimer: The above Problem (For Loops in C) is generated by HackerRank but the Solution is provided by Sloth Coders.

A Sloth Who Code

Sloth Coders

Also Read:

Sloth Coders is a Learning Platform for Coders, Programmers and Developers to learn from the basics to advance of Coding of different langauges(python, Java, Javascript and many more).

Post a Comment