Functions in C - HackerRank Solution

Today we will be solving Functions in C HackerRank problem. In this challenge, you will learn simple usage of functions in C. Functions are a bunch

 Today we will be solving Functions in C HackerRank problem

Functions in C - HackerRank Solution

Objective

In this challenge, you will learn simple usage of functions in C. Functions are a bunch of statements grouped together. A function is provided with zero or more arguments, and it executes the statements on it. Based on the return type, it either returns nothing (void) or something.

A sample syntax for a function is

return_type function_name(arg_type_1 arg_1, arg_type_2 arg_2, ...) {
    	...
        ...
        ...
        [if return_type is non void]
        	return something of type `return_type`;
    }

For example, a function to read four variables and return the sum of them can be written as

+= : Add and assignment operator. It adds the right operand to the left operand and assigns the result to the left operand.

a += b is equivalent to a = a + b;

Task

Write a function int max_of_four(int a, int b, int c, int d) which reads four arguments and returns the greatest of them.

Note: There is not built in max function in C. Code that will be reused is often put in a separate function, e.g. int max(x, y) that returns the greater of the two values.

Input Format 

Input will contain four integers - a,b,c,d, one on each line.

Output Format 

Print the greatest of the four integers.

Note: I/O will be automatically handled.

Sample Input 

3
4
6
5

Sample Output 

6

Solution - Functions in C Hacker Rank Solution 

#include <iostream>
#include <cstdio>
using namespace std;
/*
Add `int max_of_four(int a, int b, int c, int d)` here.
*/
int max_of_four(int a, int b, int c, int d)
{
    int grt;
    if (a >b && a> c && a>d)
    grt = a;
    else if (b>a && b>c && b>d)
    grt = b;
    else if (c>a && c>b && c>d)
    grt = c;
    else if (d >a&& d>b && d > c)
    grt = d;
    return grt; 
}

int main() {
    int a, b, c, d;
    scanf("%d %d %d %d", &a, &b, &c, &d);
    int ans = max_of_four(a, b, c, d);
    printf("%d", ans);
    
    return 0;
}

Functions in C HackerRank Solution
Functions in C - HackerRank Solution 

Disclaimer: The above problem (Functions in C) is generated by Hacker Rank but the solution is provided by Sloth Coders.

Sloth Coders is a Learning Platform for Coders, Programmers and Developers to learn from the basics to advance of Coding of different langauges(python, Java, Javascript and many more).

Post a Comment