Text Wrap in Python - Hacker Rank Solution

Hello coders, today we are going to solve Text Wrap in Python Hacker Rank Solution. You are given a string S and width w. Your task is to wrap the str

Hello coders, today we are going to solve Text Wrap in Python Hacker Rank Solution.

Text Wrap in Python - Hacker Rank Solution

Problem

You are given a string S and width w.

Your task is to wrap the string into a paragraph of width w.

Input Format

The first line contains a string, S.

The second line contains the width, w.

Constraints

  • 0 < len(S) < 1000
  • 0 < w < len(S)

Output Format

Print the text wrapped paragraph.

Sample Input 0

ABCDEFGHIJKLIMNOQRSTUVWXYZ
4

Sample Output 0

ABCD
EFGH
IJKL
IMNO
QRST
UVWX
YZ

Solution - Text Wrap in Python - Hacker Rank Solution 

Python 3

import textwrap

def wrap(string, max_width):
    for i in range(0,len(string)+1,max_width):
        result = string[i:i+max_width]
        if len(result) == max_width:
            print(result)
        else:
            return(result)
if __name__ == '__main__':
    string, max_width = input(), int(input())
    result = wrap(string, max_width)
    print(result)

Disclaimer: The above Problem (Text Wrap in Python) is generated by Hacker Rank but the Solution is provided by Sloth Coders.

Happy Coding !!

A Sloth Who loves to Code

Also Read:

Sloth Coders is a Learning Platform for Coders, Programmers and Developers to learn from the basics to advance of Coding of different langauges(python, Java, Javascript and many more).

Post a Comment