Vector Sort in C++ | HackerRank Solution

Hello there, today we are going to solve Vector Sort Hacker Rank Solution in C++.

Hello there, today we are going to solve Vector Sort Hacker Rank Solution in C++.

Vector Sort in C++
Table Of Contents 👊

Task

You are given N integers.Sort the N integers and print the sorted order.

Store the N integers in a vector.Vectors are sequence containers representing arrays that can change in size.

Declaration:

vector<int>v; (creates an empty vector of integers)

Size:

int size=v.size();

Pushing an integer into a vector:

v.push_back(x);(where x is an integer.The size increases by 1 after this.)

Popping the last element from the vector:

v.pop_back(); (After this the size decreases by 1)

Sorting a vector:

sort(v.begin(),v.end()); (Will sort all the elements in the vector)

Input Format

The first line of the input contains N where N is the number of integers. The next line contains N integers.

Constraints

  • 1 <= n <= 10^5
  • 1 <= Vi <= 109 , where Vi is the ith integer in the vector.

Output Format

Print the integers in the sorted order one by one in a single line followed by a space.

Sample Input 

5
1 6 10 8 4

Sample Output 

1 4 6 8 10

Solution - Vector Sort in C++

#include <cmath>
#include <cstdio>
#include <vector>
#include <iostream>
#include <algorithm>
using namespace std;


int main() {
    /* Enter your code here. Read input from STDIN. Print output to STDOUT */   
    int n; cin >> n;
    vector<int> arr;
    int x;
    for(int i=0 ; i<n ;i++)
    {
        cin >> x;
        arr.push_back(x);
    }
   sort(arr.begin(),arr.end());
    for(int i=0 ; i<arr.size();i++)
    {
        cout<< arr[i] <<' ';
    }
    return 0;
}

Disclaimer: The above Problem (Vector Sort) is generated by Hacker Rank but the Solution is Provided by Sloth Coders. This tutorial is only for Educational and Learning Purpose.

Sloth Coders is a Learning Platform for Coders, Programmers and Developers to learn from the basics to advance of Coding of different langauges(python, Java, Javascript and many more).

Post a Comment