Hello coders, today we are going to solve Simple Array Sum Hacker Rank Solution which is a part of Hacker Rank Problem Solving Series.
π Table Of ContentsTask
Given an array of integers, find the sum of its elements.
For example, if the array ar = [1, 2, 3], 1 + 2 + 3 = 6, so return 6.
Functional Description
Complete the simpleArraySum function in the editor below. It must return the sum of the array elements as an integer.
simpleArraySum has the following parameter(s):
- ar: an array of integers
Input Format
The first line contains an integer, n, denoting the size of the array.
The second line contains n space-separated integers representing the array's elements.
Constraints
0 < n, ar[i] <= 1000
Output Format
Print the sum of the array's elements as a single integer.
Sample Input
6
1 2 3 4 10 11
Sample Output
31
Explanation
We print the sum of the array's elements: 1 + 2 + 3 + 4 + 10 + 11 = 31.
Solution - Simple Array Sum - Hacker Rank Solution
Python 3
n = int(input().strip())
arr = [int(arr_temp) for arr_temp in input().strip().split(' ')]
print(sum(arr))
Disclaimer: The above Problem (Simple Array Sum) is generated by Hacker Rank but the Solution is provided by Sloth Coders. This tutorial is only for Educational and Learning purpose.