A Very Big Sum - Hacker Rank Solution

Hello coders, today we are going to solve A Very Big Sum Hacker Rank Solution which is a part of HackerRank Problem Solving Series. In this challenge,

Hello coders, today we are going to solve A Very Big Sum Hacker Rank Solution which is a part of HackerRank Problem Solving Series

A Very Big Sum - Hacker Rank Solution
👊 Table Of Contents

Task

In this challenge, you are required to calculate and print the sum of the elements in an array, keeping in mind that some of those integers may be quite large.

Function Description

Complete the aVeryBigSum function in the editor below. It must return the sum of all array elements.

aVeryBigSum has the following parameter(s):

  • int ar[n]: an array of integers .

Return

  • long: the sum of all array elements

Input Format 

The first line of the input consists of an integer n.

The next line contains n space-separated integers contained in the array.

Output Format

Return the integer sum of the elements in the array.

Constraints

1 <= n <= 10

0 <= ar[i] <= 10^10

Sample Input

5
1000000001 1000000002 1000000003 1000000004 1000000005

Sample Output

5000000015

Note:

The range of the 32-bit integer is (-2^31) to (2^31 - 1) or [-2147483468, 2147483647].

When we add several integer values, the resulting sum might exceed the above range. You might need to use long int C/C++/Java to store such sums.

Solution - A Very Big Sum - Hacker Rank Solution 

Python 3

#!/bin/python3

import math
import os
import random
import re
import sys

# Complete the aVeryBigSum function below.
def aVeryBigSum(ar):
    sum = 0
    for i in range(ar_count):
        sum = sum + int(ar[i])
    return sum

if __name__ == '__main__':
    fptr = open(os.environ['OUTPUT_PATH'], 'w')

    ar_count = int(input())

    ar = list(map(int, input().rstrip().split()))

    result = aVeryBigSum(ar)

    fptr.write(str(result) + '\n')

    fptr.close()

Disclaimer: The above Problem (A Very Big Sum) is generated by Hacker Rank but the Solution is provided by Sloth Coders. This tutorial is only for Educational and Learning Purpose.

Sloth Coders is a Learning Platform for Coders, Programmers and Developers to learn from the basics to advance of Coding of different langauges(python, Java, Javascript and many more).

Post a Comment